×

IDMWORKS Blog

Will The Real PACLI Version Stand Up?


PACLI (Private Ark Command Line Interface) is distributed in both the AIM and EPV CD images. Inside of the EPV, PACLI can be found in the Password Upload Utility directory.

You might not notice that the two are different versions. The AIM distro uses version 9.9.5, while The Password Upload Utility uses PACLI version 4.10.x.  A little hunting and you’ll find that v9.9.5 is the highest PACLI version number from any distribution.

If you use PACLI v4.10.211.0 the Enable Access to Fully Impersonate Users right is REMOVED after using passwordupload.exe.  In short, your inventory reports will exclude any safe that this isn’t enabled.

If you’re like me, you try to standardize to prevent a proliferation of various versions. That said, PACLI 9.9.5 has a glaring issue that it is only 64-bit. The 64-bit version has issues when using PowerShell to wrapper PACLI commands. In particular the safelist function.

So for many folks, you will need the 32-bit version. To find the latest 32-bit version, you’ll need to go all the way back to PACLI v9.8 from the PAS 9.8 AIM CD.

Questions, comments or concerns? Feel free to reach out to us below, or email us at IDMWORKS to learn more about how you can protect your organization and customers.

Leave a Reply

Your email address will not be published. Required fields are marked *